【原创】如何安装appium(在npm安装总是出错时)

本文意在帮助读者在使用npm安装appium总是出错时,如何来完成安装,详见文章;作者:沙陌 appium交流qq群:534129320,转载请注明
前提条件:node、jdk、sdk等所需软件均已装好,只剩下appium在使用npm -g install appium安装时总是出错无法安装成功的情况下;注意文内红色文字为作者本地独有的路径,请读者酌情根据自身目录进行替换
作者:沙陌 appium交流qq群:534129320
相关文件下载地址: 链接:https://pan.baidu.com/s/1pMHcxN9 密码:q5io
一. windows下安装appium1.7.2
1. 下载网盘中的appium.zip、appium-doctor.zip、appium.cmd、appium-doctor.cmd
2. 将appium.zip和appium-doctor.zip解压至本地C:\Users\LXG\AppData\Roaming\npm\node_modules目录下
3. 将appium.cmd和appium-doctor.cmd放在C:\Users\LXG\AppData\Roaming\npm 目录下
4. 配置环境将C:\Users\LXG\AppData\Roaming\npm增加至环境变量path中(如果已经配过就不必再配)
5. 在命令行执行appium-doctor检查环境安装是否正确,没有错误后执行appium启动appium1.6.3的服务
二. mac下安装appium1.7.2
1. 下载网盘中的appium.zip、appium-doctor.zip
2. 将appium.zip和appium-doctor.zip解压至本地/usr/local/lib/node_modules
3. 命令行进入cd /usr/local/bin 目录下,分别执行以下两个命令
ln -s /usr/local/lib/node_modules/appium/build/lib/main.js appium
ln -s /usr/local/lib/node_modules/appium-doctor/appium-doctor.js appium-doctor
4. 在命令行执行appium即可运行appium1.7.2
如果碰到错误如下
Error: Cannot find module '/usr/local/lib/node_modules/appium/node_modules/sqlite3/lib/binding/node-v51-darwin-x64/node_sqlite3.node'
解决方法,命令行执行cd /usr/local/lib/node_modules/appium/node_modules/ 然后执行npm install sqlite3 安装完成后再次执行appium即可

  • 发表于 2017-02-23 22:20
  • 阅读 ( 3911 )
  • 分类:默认分类

0 条评论

请先 登录 后评论
不写代码的码农
沙陌

神一样的存在

14 篇文章

作家榜 »

  1. hey girl 181 文章
  2. 王前前 137 文章
  3. 柠檬 118 文章
  4. lamking 105 文章
  5. 云少 105 文章
  6. 腾讯移动品质中心TMQ 104 文章
  7. humortony 82 文章
  8. 开心的阳光 41 文章